#102 Error when saving album settings from the settings tab

Suljettu
1 vuosi sitten avasi aheathershaw · 2 kommenttia

When you edit an album’s settings within the Settings tab of the album itself, you get an error.

Changing the album through the album’s edit screen works fine.

When you edit an album’s settings within the Settings tab of the album itself, you get an error. Changing the album through the album’s edit screen works fine.
aheathershaw self-assigned this 1 vuosi sitten
aheathershaw added the
bug
label 1 vuosi sitten
aheathershaw commented 1 vuosi sitten
Omistaja

This is due to the validation added in #58, allowing albums with the same name to exist under different parents.

The settings tab does not have the “parent” field that the Edit screen does, so it causes an undefined index trying to access the field’s value.

The validation needs to use the album’s current parent when this field is not present in the data.

This is due to the validation added in #58, allowing albums with the same name to exist under different parents. The settings tab does not have the “parent” field that the Edit screen does, so it causes an undefined index trying to access the field’s value. The validation needs to use the album’s current parent when this field is not present in the data.
aheathershaw added this to the (poistettu) milestone 1 vuosi sitten
aheathershaw commented 7 kuukautta sitten
Omistaja

This is also present in Cloud, needs fixing in 2.2.0 and merging across.

This is also present in Cloud, needs fixing in 2.2.0 and merging across.
aheathershaw modified the milestone from (poistettu) to Version 2.2.0-beta.1 7 kuukautta sitten
aheathershaw added the
wip
label 7 kuukautta sitten
aheathershaw removed the
wip
label 7 kuukautta sitten
Sign in to join this conversation.
Ei merkkipaalua
No Assignees
1 osallistujaa
Due Date

No due date set.

Dependencies

This issue currently doesn't have any dependencies.

Loading…
Peruuta
Tallenna
Sisältöä ei vielä ole.