#102 Error when saving album settings from the settings tab

已关闭
aheathershaw1年前创建 · 2 条评论
aheathershaw 评论于 1年前

When you edit an album’s settings within the Settings tab of the album itself, you get an error.

Changing the album through the album’s edit screen works fine.

When you edit an album’s settings within the Settings tab of the album itself, you get an error. Changing the album through the album’s edit screen works fine.
aheathershaw1年前 指派给自己
aheathershaw 添加了标签
bug
1年前
aheathershaw 评论于 1年前
所有者

This is due to the validation added in #58, allowing albums with the same name to exist under different parents.

The settings tab does not have the “parent” field that the Edit screen does, so it causes an undefined index trying to access the field’s value.

The validation needs to use the album’s current parent when this field is not present in the data.

This is due to the validation added in #58, allowing albums with the same name to exist under different parents. The settings tab does not have the “parent” field that the Edit screen does, so it causes an undefined index trying to access the field’s value. The validation needs to use the album’s current parent when this field is not present in the data.
aheathershaw 1年前 添加了里程碑 (已删除)
aheathershaw 评论于 7 个月前
所有者

This is also present in Cloud, needs fixing in 2.2.0 and merging across.

This is also present in Cloud, needs fixing in 2.2.0 and merging across.
aheathershaw 7 个月前 修改了里程碑从 (已删除)Version 2.2.0-beta.1
aheathershaw 添加了标签
wip
7 个月前
aheathershaw 删除了标签
wip
7 个月前
登陆 并参与到对话中。
未选择里程碑
未指派成员
1 名参与者
到期时间

未设置到期时间。

依赖工单

此工单当前没有任何依赖。

正在加载...
取消
保存
这个人很懒,什么都没留下。