#84 Child albums displayed incorrectly

Closed
opened 1 year ago by aheathershaw · 2 comments

On the demo system when you are logged in as the demo user, every album shows all albums as children, even though only 1 is a child.

Additionally the “albums” admin screen hangs and doesn’t load, presumably because it’s getting into an endless loop if every album is also being seen as a child of itself.

On the demo system when you are logged in as the demo user, every album shows all albums as children, even though only 1 is a child. Additionally the “albums” admin screen hangs and doesn’t load, presumably because it’s getting into an endless loop if every album is also being seen as a child of itself.
aheathershaw self-assigned this 1 year ago
aheathershaw added the
bug
label 1 year ago
aheathershaw added this to the Version 2.1.2 milestone 1 year ago
aheathershaw commented 1 year ago
Owner

This is due to an incorrect join on user permissions - when logged in as a user, and filtering by parent, the “and” clause is incorrectly mixing with the OR due to lack of brackets around the ORs for the permissions.

This is due to an incorrect join on user permissions - when logged in as a user, and filtering by parent, the “and” clause is incorrectly mixing with the OR due to lack of brackets around the ORs for the permissions.
aheathershaw commented 1 year ago
Owner
Migrated from https://github.com/andysh-uk/blue-twilight/issues/84
Sign in to join this conversation.
No Milestone
No Assignees
1 Participants
Due Date

No due date set.

Dependencies

This issue currently doesn't have any dependencies.

Loading…
Cancel
Save
There is no content yet.